[Pyramid] Is there a way to enable patterns for all tracks?


#1

It’s kinda weird how we have to enable pattern mode for each individual track. Is there a way to make it so all tracks have this mode enabled by default? I suppose I could just go through and enable each one manually and then save it as default, but that feature has been glitchy for me in the past.

Honestly I’m just curious why you have to enable patterns for each track manually - I wonder if it’s a technical limitation thing? Anyways, just wondering if I’m missing something, and if I’m not, just bringing it to Squarp’s attention (though they have more than enough on their hands already!).


#2

Patterns were added at v2.0 so they weren’t planned at the start. It’s not clear that everyone would want them enabled by default (I know I don’t) or how they would play out with customers in general. So they are disabled by default.


#3

Perhaps create a template project, load that when you want to start new, and be sure to [Save As…] to a new name so you dont overwrite your Template Project…?


#4

This is a track setting, not a default setting. Go into each track, enable pattern for all of them ( set a default midi channel and a name while you are at it ) and save the settings. There’s an example of what to do here: ( I made this video )


#5

@mongrol Fair enough, I’m just confused as to why people would not want them enabled - do they do anything negative to your workflow if they are turned on? I’m just wondering, as far as I can tell a track with patterns enabled works exactly the same as a track without, except you can use patterns if you’d like to.

Yeah @o_0 / @CreepyPants, that was what I referred to when I mentioned going through each one manually and saving it as default - I’ll probably do that soon, but it’s quite a bit of busywork for a feature that doesn’t seem to disrupt anything when it’s on. I wish there was just a setting called “Default Pattern Mode”.

Not a huge deal I guess, just thought I’d reach out. Thanks for the responses.


#6

i suspect its because pattern tracks save as midi type 1 files, non use type 0.
type 1 is a bit more complex (slower/higher cpu?)… but also by having it off by default it backwards compatible with previous os versions.

just a guess, as i dont have access to the source code, so cant know for sure :wink: