Problem: Pyramid skips first step in sequence


Did this ever get resolved? I can’t seem to get it working properly, even on the latest beta


When recording live, if the first note occurs a bit early, it can end up as the last note of the track so it wont play when the track starts but it will play when the track loops. See Note offset +/- 50% - is it ever going to happen?, this is quite a common problem.


Thanks, but I’m still having it with step recording too


I am not having this problem.

I have all kinds of data on all sorts of tracks at 1.1.0 and do not have midi notes dropping out.
I’ve got a Pyramid MK1 and haven’t seen this on any version of the OS.

However, I do have an evolving program change issue. Originally the program changes would upset the notes, and I talked it over with @squarpadmin via email and in an update the notes stopped getting cut out, but the program changes started to take a cycle to kick in.
I walked this over more with Squarp via email and eventually the problem seemed to go away. I figured they worked it out.

In the most recent rounds of changes (from 2.3 - the current beta) the program change delay/note dropping out issues have returned.
I wonder if you have program changes on 1.1.0 in your patterns/tracks?

If you do, try removing them as an experiment and see if that brings your notes back on the 1?

This could be a data hierarchy issue which can be solved, and has been solved before, but is easily overlooked because not all gear responds to program changes the same way (ex: The Access Virus just can’t do it on the 1, the Roland Boutiques glitch on the 1, and the OB-6 works like a charm no matter when you sent it.)


Thanks, I’ll investigate your suggestion and report back, I suspect something else is going on, because I’m usually starting from a blank slate. Either way, I’ll look into it


Hi guys,

We did not notice any PROGRAM CHANGE and NOTE issues with the current beta. Do you have a procedure to reproduce this bug, if it still occurs with your setup?

You can use MIDI monitor (MacOS) or MIDIOX (Windows) to monitor the data sent by Pyramid.

I just made some tests. When no PC are set, and you press play, Pyramid send in this order:

  • NOTE ON of the step 1
    (these midi messages are following each other very very closely)

When a PC is set, and you press play, Pyramid send in this order:

  • NOTE ON of the step 1

@Sunshine @Ptbarnum @pmatilai Maybe it comes from your midi synth. Can you please precisely describe your problem, so I can investigate it further?

Thanks a lot!


I had a weird issue where one of the patterns would start at the second bar in sequence mode.


When you say it might come from our midi synth, what settings should we look for as the cause? It’s a frustrating bug hard to tell what is causing it


Do you have your faulty project, with a procedure?

You can use a midi monitor to see if the midi messages sent by Pyramid are on time.

I don’t know if your issues came from Pyramid or from your synths, because I don’t even know your problems :slight_smile:


Gotcha, I’m assuming it’s a pyramid problem, because I’ve rotated through various synths, and the problem persists. I’d be happy to email you a project that demonstrates the problem👍


@Ptbarnum Great, you can send us your project at contact(at)squarp(dot)net !


Will do today


@squarpadmin, the thing I was talking about is pretty well covered in topic I linked earlier. It’s not specific to the beta, I know I’ve seen the phenomen on v2.30 but don’t have a reproducer at hand and couldn’t create one yesterday when I briefly tried to.

That said, there are clearly several different issues being talked about in this topic. And while checking the sounds of a newly acquired expansion board for my JV-1080 today, I realized that on some patches have a very noticeable loading time, probably closer to half a second worst case. The behavior is such that if you select a new patch and then quickly hit a note, the note will start playing after the load has completed but a 1/8 or 1/4 note could easily get lost in there. And that wouldn’t happen on the next loop of course because the patch is already loaded. However I don’t remember seeing missed notes with step-entered data so … I dunno. I’ll keep an eye on it and investigate closer if/when it happens next time.


I’m having the same issue (first note is skipped) on a project. I’ve tried quantizing via FX, offsetting the note but nothing seems to work.

In my case a program has been assigned to the problematic track, which seems to be what causes the misfire (upon initial play only).

Have any workarounds been discovered?


I haven’t had this problem but I also always put my program changes on their own tracks so I can have them play one shot and sequence them in more ways. It doesn’t fix your problem but it might be the simplest solution if you have empty tracks to spare


Great suggestion—that’ll work for me.

Seems like it can generally be good practice too—to allow for multiple “program” tracks to affect the same pattern over the course of a song or performance…


I have the “missing first note” issue when playing pattern chains in SEQ mode when I have a note on the first beat, quantizer on, and HUMAN- in the quantizer set to some non-zero value. Sometimes the first note plays, and sometimes it doesn’t. I speculate it’s because the HUMAN- setting is sometimes setting the note to sound early and so doesn’t get played when a new sequence starts. If I set HUMAN- to zero, the first note always plays.

IIUC, the HUMAN settings are supposed to cause variations in the timing, so it kind of makes sense that a note at 1.1.0 might get moved to an earlier time and so might not play when that sequence is switched to. That said, it definitely seems wrong that something as fundamental as a kick drum on beat 1 would sometimes not happen. I would hope they could make the sequence chaining function smart enough to allow the first note of the next sequence to occur early. Alternatively, they could make the humanize function never make the first note earlier.

I sent a bug report to Squarp a week or so ago with steps to reproduce this issue, but haven’t heard anything back from them.

But the above discussions about CCs and PC makes me wonder whether the HUMAN settings in the quantizer are applied only to notes, or to any/all kinds of data. Anyone know the answer?



I also have this “problem” I consider it for me a minor issue tho


Hi all.

Did this missing first step issue get fixed?

It’s putting me off buying the Pyramid atm.

Missed first step can be a common problem with some sequencers, and it’s pretty frustrating to deal with.



New Pyramid user here. I can reproduce this & the seeming intermittent occurrences:

Track 1: 1 bar
Track 9: 4 bars (with note on first step)
Seq 1: Track 1
Seq 2: Track 1 & Track 9
Sequence chain: Seq 1 plays for 4 bars - result: when seq changes to seq 2, first note on track 9 triggers OK.
Sequence chain: Seq 1 plays for 2 bars - result: when seq changes to seq 2, first note on track 9 does NOT trigger.