Power-on issue (button)


#1

Hi there, I bought my Pramid used, so I guess I’ll have to deal with some minor issues, but this is a weird one: I power my Pyramid from a powered USB hub, and use USB midi and sync. Pyramid is slaved to external clock, via a iCM4+ midi interface.

When I power up the Pyramid using the on/off button, USB doesn’t work . I get no input no output, clock included (but the settings are OK, I checked, they are loaded from the SD card)

If I leave the power button in the “on” state and unplug/plug in the USB lead physically, no problem, I get midi and sync. Doesn’t matter which side of the USB cable I unplug/plug. I tried 3 different cables. My powered hub has a on/off switch. That works too. So it’s really only when using the Pyramids on/off button. Not a big deal now that I know what to do, but I had a serious WTF moment (including changing SD cards, reformatting, resets… everything you could think of.
I believe that it worked as expected when I got it (that was only yesterday) and I upgraded to the latest firmware just after checking that the basic functionalities were OK. I think but I’m not sure, that there could be a relationship. Any thoughts?