New user, having midi in and some other questions

Hey,

new user here

after almost 2 years on the waitinglist for a cirklon I decided to try it with the Pyramid, have it for a few weeks now and love it so far. very nice to build track, my main purpose was to play livesets with it but not enough pattern room per project which is a bit of a shame. But really like it anyway

so… i have a few problems. all my midi out works perfectly but i have problems with my midi in. I have a kenton merge8, all my keyboards work fine on the input, same for my keystep but the things that don’t work are this: i would like to record all my patterns from my analog rytm, OB-6, toraiz as-1 and digitone. but everytime i connect these midi out from my device to the merger both the device and the pyramid are freaking out and even block so i have to reboot. for me the synths are not really such a big deal although it would be nice if it worked. But the RYTM i would really make this work, would record full tracks from 200 bars or so so i can play these as full tracks. i’ve read topics on this forum first but the things i tried didn’t work for me, the echo option is set to stop echo, so it’s not that… anyone maybe have a RYTM or another synth i have and know how to set the midi settings in the devices itself.
second problem is the definition files, some work, some don’t, midi cc’s are not the same as in the definition file, the names of the notes (like with rytm c-1=bd) never appear, does this have a reason why this is not correct on my pyramid? the names of the definition files are correct though.

these are the only things i struggle with, besides that all is perfect

if anyone could help me with this… would be nice :slightly_smiling_face:

thanks in advance

Remy

Can you describe “freaking out”?

have you tried connecting just ONE of these devices directly to the Pyramid to test out if that works properly?

Is there a difference in format between the ones that work and the ones that don’t?
Perhaps you can post one of your def files that does not work and we can see if there’s something in the format that might be causing your issues.

Check out your MIDI OUT settings for unintentional THRU modes and that OMNI and MULTITRACK match intended use (IIRC the defaults are for one master keyboard on input). Beyond that, like @CreepyPants points out, connect the problematic things one by one and see where the problems start occurring. MIDI monitor is also essential in troubleshooting.

As for definition files, sorry if this obvious but did you realize you need to edit them (CHANNEL and OUT) to match your setup?

Its like everything starts to blink, my rytm his bpm goes to 300 and can’t do anything with it anymore, same for pyramid, can’t press start, it just blocks, i think it’s because midi is going out and coming in too and it clashes

Yes i tried it, same story with the rytm, didn’t try it with the other devices

No, they are all the same format, i can call all of them but cc’s don’t match from all of them, especially from drum boxes, some synths are correct, others not

will search a bit more today, thanks for the help

all midi outs are on out, not thru, that multitrack option in settings i don’t understand totally… will have to try it out some more, it was on multitrack off, so, let’s say, if my rytm is on bank A i should choose multitrack bank A then? or do i need to choose a midichannel 1-16? 2 choises… will try that out

As for the definition files, yes, all my drums are on bank A, all synths on bank B, so yes, Rytm is channel 1A, and set this the same in the file, channel 1, out A. same for synths, dominion 1 is B1 etc… will check them all again but think i did the right thing.

anyway, thanks for the help, i will try some more and if it really doesn’t work like i want i come back here

cheers

Sounds like a MIDI loop.

Except he said it does it when the only connection is AR Out to Pyramid In.

That’s…frightening

so, tried some different things today but still no succes. what i did: I made the AR master and the pyramid slave, i only connected the AR midi out to the pyramid midi in, works. the strange thing is, if i hat a pad i see a midi signal coming in, if i record that in live mode, no notes show up even if the midi in Arrow flashes everytime i press a pad on the AR. but what i want to do is record all my sequences from the AR into the pyramid, but if the pattern plays, all the trigs and notes that play don’t show any midi signal coming in, it does when i press a pad on the AR but even when the signal comes in it does not record… i’m a few steps further but it’s strange it does not record anything from it while it receives midi signals

i thought that is not possible when echo off is selected

no, that’s the thing i tried now but the outputs of my pyramid was still connected to the input of my AR yesterday, i know now if i want to do what i want, it’s best to disconnect the input of the AR

if i *press a pad

if your tempo is jumping to 300, its a midi clock loop

echo off, does not prevent this - afaik its for notes only.

sync is handled separately on the pyramid, and so it comes down to sync settings on MIDI IN and MIDI OUT. - there are separate options for clock for both USB And MIDI DIN.

the other thing that is very useful is to look at the midi monitor -> SETTINGS -> INFO (midi input/output etc) … you can check there to see if you are sending and receiving what you expect.

note: clock is also not per midi channel, its global - so multichannel will not affect it. I would leave OMNI = off for now. multibank is used when you want different midi channels to talk to different tracks.

1 Like

ok, thanks for your input,
will try some more :slight_smile:

Probably what I am going to type is not very important but …

It has been said already, but the 300bpm happened to me, when I made the mistake of leaving on my clock send and start/stop send in my octatrack.

The weirdest problem I have (every time I turn on my set up) is, that I have to reset the midi through on my Toriaz SP 16. It is already set to midi through, but I have to set to a different midi out setting and then back to midi through, for the midi through to work. How I figured that out is still a mystery to me. All I know is that it was mysteriously working, and then it was not, so I just kept trying everything. I guess what I am trying to share is that problem solving is step by step process and can be frustrating.

1 Like