MIDI THRU off, should Hapax be repeating every note?

I’ve got all of the MIDI THRU options set to “OFF.”

Track 13 is set to MIDI Device Channel 13 on input and output. No other tracks are on Channel 13

Even so, when I play my drum machine in track 13, the MIDI monitor reports Hapax is repeating every note. MIDI Wrench on this iPad confirms this.

Am I missing something? Is Hapax supposed to echo everything on the same channel, even with all MIDI THRU options turned off? If so, is there any way to prevent this?

why would you want the drum machine to be sending output to Hapax on Ch 13 (if I’m reading your setup description correctly)? that’s just going to cause a MIDI feedback loop. i only ever output MIDI notes on a Drum Track and use a MIDI keyboard for selecting note values on that track if I want to step program patterns

Have you got thur switched on , on the drum machine?

When you are getting the repetition of every note, do you have track 13 highlighted? I believe that the Hapax echos every note on the currently selected track to its output channel, whether or not you have Thru enabled.

The workaround is to change the input or output of that track so it doesn’t send data back to itself (although in my experience you don’t actually get MIDI loops - not sure if this is due to Hapax or my synth, though, tbh)

I can easily imagine someone would want to take a beat one has programmed on a drum machine, and record it as a midi pattern on Hapax to keep things together when saving, for example.

As for OP question:
I think the MIDI thru is related to whether incoming MIDI gets sent out again immediately, irrespective of what the in/out midi settings are for individual tracks. https://squarp.net/hapax/manual/modesettings#Ah1coyV
On the Pyramid there was a setting called MIDI Echo, which would prevent incoming midi to be sent out over the same channel. This was to help with synths that didn’t have Local Off settings available.
This doesn’t seem to be available (yet?) on Hapax.
Is the problem that the drum machine double trigger notes because it is receiving the notes it is sending out itself?
For synths in this scenario you would usually set the synth to Local Off, but for drum machines I can imagine it gets a little bit more complicated.
Is there a problem when triggering the drum machine from Hapax?

Thanks everyone for the quick and informative responses!

@chrisroland I use the BeatBuddy to generate beats that I record into track 13. Once I’ve recorded the beat (with fills and transitions generated by automation CC’s sent by the Hapax), I play it as any other track in the song. At times I use another track configured with drum lanes when I want to play something using BeatBuddy as a drum sound module, as opposed to using the pattern already available in the BeatBuddy.

@aldred it’s Hapax that’s echoing the notes, not the BeatBuddy drum pedal. When Hapax is off, I don’t see this doubling in MIDI Wrench on my iPad.

@Loz I do have track 13 highlighted, as it’s the track I’m recording, as described above. Your workaround is definitely doable, though it would prevent the automation I use in the track from transmitting, and that’s a key element in my workflow at the moment.

So far I’ve seen no ill effects from this message doubling, but I’m always concerned about extra MIDI messages floating around. Are there any other ways to shut off this doubling?

Did you save the midi thur settings on the hapax ? , I remember not saving them the first time I turned them off

Yeah, I have this issue on my Nord, as it’s plugged into the Hapax both in and out. The MIDI channel workaround is a bit messy, but it does work.

When thinking about it when replying to you, I came up with a suggestion I’ve sent to Squarp, which would be able to have the option to mute MIDI echoes on a particular track, so it would only play notes already inputted. We’ll see what they say.

@aldred I confirmed that the settings were saved.

@Loz I appreciate that you’ve suggested this to Squarp. For all intents and purposes, every one of my instruments is connected to in and out (virtually through a MioXM). I would prefer to have explicit control over this echoing.

I looked at the beat buddy manual, are you sure the bb midi out isn’t set to merge

@aldred Thanks for researching!

Yes, I just confirmed that “Output Type” is set to MIDI OUT on my BeatBuddy.

Anyway, since I don’t get this doubling when Hapax is off, it seems clear that it’s coming from Hapax.

It seems that Hapax, in it’s current firmware revision, is built on the assumption that it will be the centerpiece of a rig. If your controller keyboard is “behind” Hapax and the tone generator “in front” of Hapax, you need MIDI echoed.

In my case, the hub of my rig is an iConnectivity MioXM. Every keyboard and MIDI generator is connected to every tone generator I have, through the MioXM.

An “off” switch for this doubling behavior would be helpful, at least to me.

Thanks again. This community of users is fantastic, and I’m so glad to have joined!


This is exactly it, I reckon. And probably in 95% of cases (including mine for the most part) its true. But turning off MIDI echo per track would be an ace addition, I reckon, make the Hapax much more flexible in its positioning.

I sent in a feature request as well.

Squarp did confirm that midi echo settings are planned in a future update

1 Like

Squarp is highly professional. No surprise. Eventually we’ll get every feature we really need in this product.

1 Like