MIDI channel: active track and USB device

Hi Everyone!

I have an external controller (Faderfox EC4) connected to the Hapax as a USB device. My problem is that the Hapax will only forward messages from the Faderfox on the active Hapax track’s channel. That is, if the active Hapax track is on channel 5, and the Faderfox sends messages on channel 3, these are not forwarded to a MIDI out of the Hapax.

Is there a setting to tell Hapax to let all incoming USB device messages through, regardless of their channel?

Hi, it sounds like you want Midi Thru, have you tried that?
Details in the very excellent online manual here: Hapax Manual | Squarp instruments

2 Likes

Mmh. Why did I not find this myself? I’ll try it and report back. Thanks for this @Jimantronic !

1 Like

Okay thanks, it works.

I realized I had actually tried the MIDI THRU settings, but I understood it the wrong way around (and still do). For this to work, I activated

  • Host ➤ MIDI A : ON

which is weird, I think, because the Faderfox is a device rather than a host.

What am I not understanding here?