Load menu freeze


Last night I had good fun with the Pyramid, saved the project, just like always. This morning the load menu freezes as soon as I click load. I didn’t switch cards or made any other change.

I tried another power source, no luck. I tried another empty formatted card and that works. I formatted the Pyramid card and that works. However, as soon as I copy the contents back on the card, it freezes.

There’s quite a lot of files on the cards, all projects and other pyramid files. Is there a limit to the number of files it can handle?

It’s quite a nuisance!

Thanks very much and have fun rolling into a musical and healthy 2020!


1 Like

well things all media (e.g. sdcards) / filesystems have limits, but you’d think hard for a user to hit.
also, its possible the pyramid might have an issue depending on how its coded.
(its not loading all the projects, but the load screen might have issues with large numbers of directories?)
… but not seen it reported here before. …

but who knows … im sure there is a limit at some point, but no idea where that is…

to test, you could backup your SD card,
then delete a few projects, and see if it starts working.

the other possibility to perhaps test for is to see if one of the projects has been corrupted.
Id assume one of the recently saved ones.

id also copy all of the projects on to a fresh sdcard to see, again in case an issue with the sdcard for a particular part of the ‘drive’.

once you work this out, then can then contact squarp with a bug report detailing what you have found.


also this will hopefully mean you can recover some of your projects.

if its number of projects, I guess thats an enhancement request,
if its a corrupt project, then they’ll like want to see it , to try to determine if its ‘media failure’ (which can happen) or pyramid writing bad project data. (if the later they might be able to help you recover it)