Live Looper should retain length after first pass, yes?

My understanding is that when using Live Looper mode, it should record for as long as you play (until you punch out), then loop back to the beginning. At that point the length should be fixed.

What I’m seeing: in Live Looper mode, it records for as long as I play, then loops at the expected length when I punch out. But if I do any overdubs (i.e. I press record again), the length is again able to be changed. I.e. if I record 4 bars with the Live Looper, punch out / stop, then enable record again, I can play endlessly beyond those 4 bars and that becomes the new length. Or, more problematically, if I stop recording at bar 2, it cuts off bars 3 and 4 and shortens it to a 2 bar loop.

Yeah I’m pretty sure it’s wrong - the docs say it should work as I expect it to:

In this mode, the length of a track grows to fit your initial performance.Press rec to start recording a loop. Press rec a second time to stop recording. Track length is now fixed.

I don’t recall it happening before. I wonder if this was introduced with v3.23. Can anyone reproduce?

I just updated to 3.23 and I’m not seeing that here. The loop length remains fixed no matter how long or short my overdubs are. The only way I’m able to change the loop length is to hold 2nd + delete, which obviously deletes the original loop and starts a new one.

Thanks for having a look - I appreciate it.

In case it wasn’t clear above, it only happens if I stop the transport completely - then enable Record + Play again to start recording from the top of the track. It doesn’t happen if I am playing back the part, then hit Record to punch in on the fly.


Ah, OK, I misunderstood the part about completely stopping and restarting with record enabled… Yes, I see that behavior if I stop the transport, then hit record, then hit play. It plays the existing loop but truncates or extends it as you describe when I hit record again.

I went back to 3.22 and I see the same behavior there, so it’s not new in 3.23. It is strange that it only happens if record is enabled when you hit play; If you hit play first and then hit record, it works as expected. (Of course in that case you would have to wait for one loop if you wanted to overdub at the very beginning.

Thanks again for having a look - and trying it on 3.22!

So I guess we have to conclude that it’s by design…? A find it a little weird, as I can’t think of a use case where you would ever want to overdub and have the pattern shorten…or have an existing pattern lengthen because you didn’t get out of record fast enough :laughing:

But, at least there is a workaround (press Play and then punch in)!

yeah, its a bit of an odd one…

basically, pressing REC then PLAY acts like a new loop…

so, I actually expected to not overdub, but rather just record new.
I guess this ‘faux’ overdub, is useful if you device you want to add to the end of it?

what is nice, is 2nd+REC -> PLAY - this then does a hard rec into a fresh loop. this i found quite useful - if you screw up the first take :slight_smile: