Issue with recording arpeggios

Hey Squarp Community,

In Live Mode if I hit record while already playing notes, the Pyramid doesn’t play the arpeggiated notes with their distinct gate length but plays them longer resulting in some weird legato chaos. After a couple of steps the arpeggio starts playing with the normal gates.
Did anyone else experience this problem?

Thanks,

Korbi

1 Like

Are you playing the arpeggio or using the arpeggiator FX?

I’m using the apeggiator FX.

When recording with the Arp FX, the recorded notes are the incoming MIDI Note Events, not the results of the arpeggiator.

For example: I can record a simple triad. If I’m playing and recording this Live, then what is recorded by the Pyramid is the triad I’m playing. What is output are the calculated arpeggiated notes.

If you want to ‘write’ the arpeggiated notes to the Track, so that the arp notes with gates are written, I believe what you’re looking for is the Consolidate function:
Manual > Track Mode > Track Options > Consolidate

If I’m understanding what you’re describing & desiring, this sounds likely to me.

3 Likes

Okay,
It’s hard to explain ,so I’ve made a Video:

To narrow things down:
The issue appears when live looper mode is on and only if the set track length before starting the new loop is longer than 1 bar. Does that make any sense?
Of course I could always check and see if the track length is 1 bar or lower, but I’m making live impro music and it would be nice if there would be one thing less I have to remember.

3 Likes

Thanks for the vid.
I completely misunderstood.

Love the knobs on your Pyramid, btw.

So, maybe someone who has experienced this might chime in. Until then:

  • are you using the latest PyraOS
  • does this happen on a brand new project
    etc
  • edit to add: and make sure there are no Arp FX or CC modulations on the Track.

…and other grunt work SOP troubleshooting steps are all I have until i can try to dupe it.

3 Likes

Another thought is this might be a thing.
Logically, if you are already holding notes before you hit [Rec], then I wonder if the Pyramid ‘assumes’ a Note On Event…and if not, does it record the corresponding Note Off Event…? Whut?

Truly for best results you want to play the Notes after you hit [Rec] to actually record the note, no?

Since I live in the State of Confusion full time, I may be drinking the water here and misunderstanding some more.

Edit to add: I just tried to mess it up, but it seems Pyramid is smrt in that it recorded the Note On at the point I press [Rec]. Nice! I need to remember that.

Yeah, the only way I can dupe this is if there is FX Modulation there.

On the Track Window, is there a tab for [FX~]?

(There is [FX] with blocks, and the [FX~] with a sine wave - looking for the latter)
If so, there might be FX modulation on the Track.

2 Likes

same as @CreepyPants, I cannot reproduce this…

listening to your video, it sounds like something is sending pitchbend messages.
arp does not send pitchbend, so either something coming in… or there is some fx like an lfo or glide, or the midi stream is somehow getting corrupted.

so, first thing I would do is use the built-in midi monitor in the pyramid to see what midi messages are being received, and what are being sent out (settings -> info -> midi in/midi out)
this will hopefully give you a clue to what is happening.

e.g. is the pyramid sending out pitchbend message (and why?!) or is perhaps your midi stream getting corrupted outside of the pyramid.

2 Likes

Curiously enough, I can “duplicate” this by creating an FX modulation for Arp Gate.

I only mention that because Im undercaffeinated right now and when i did it yesterday it sounded super cool. Im going to use that on something - if you have control of it, it’s fun!

But yeah: thanks @thetechnobear for the MIDI monitor troubleshooting step - i keep forgetting that bit

3 Likes

This issue is quite complicated, and I’ve tried to narrow it down.
I’ve made another video where I open a completely new project and just send CV and Gate. No Midi IN/OUT connected. And I think the problem only happens when I press record if there’s still 3 or 4 beats left of one measure. If I press record later on, the arpeggiator seems to work normal (as you can hopefully see in the video).

Thank you all a lot for your efforts to help me. It’s really nice to see that Squarp has such a great community.

Oh, and I’ve forgot to mention, the notes with longer gate that appear in the beginning are not recorded. If I replay the sequence again the notes have their normal gate length.

1 Like

This is a clear video - excellent.
Perhaps Technobear can be of assistance because I don’t CV. Sorry.

Another thing to review is the monitor for the CV Outs.
It feels to me like something isn’t getting a Note Off/Gate Low (?), but again: I don’t CV so I don’t know what to look for downstream - checking the monitor is the best way to see if the Pyramid is at least reporting that it’s doing what is expected.

1 Like

The CV output shows that the gate is completely open when the thing happens, but that’s what I supposed to find. The Midi output doesn’t differ from when the arp plays normally.
I tried a lot to replicate this issue under different circumstances and it’s really hard to find a pattern, it really seems to happen randomly. Any patterns that I thought I could see disappeared after trying it for a couple of times. I have no idea what else I can do more.

Thanks for following up.
And again: apologies for being daft.

If I understand your most recent post:

  • The Pyramid Monitor is showing that all data is being expressed as intended
  • MIDI Data doesn’t differ, which I assume is correct since we’re dealing with a CV Track
  • The problem happens sporadically, without pattern

If the Pyramid Monitor is showing the data as expected, then I’m thinking 3 things might be an issue:

  • The Pyramid is lying (or rather, giving us an incomplete picture of what is being sent out of the ports)
  • The data is correct, but being mishandled on the downstream (synth) side of things
  • The hardware connection is problematic

Perhaps take a look at your modular patch?
Do you have modulations that may affect the incoming Gate signal or affect how the patch responds to Gate signals?
Perhaps a super simple simplest simpler as simple as simple can simple patch to see if you can dupe it, then add on from there?

Again, I’m not a CV person so I’m completely at a loss. Sorry.

I can achieve a similar effect on my Minitaur, btw. When I send Note Off after the next Note On. I haven’t tested this with any mono patches on my digital synths, tho. This is what leads me to feel that a Gate Off (?; “gate low”? - I don’t know the term) isn’t getting to the synth in the way that we want with regularity.

I’d still be curious to see the .mid file & Pyramid file this occurs on.
Since you can make this happen from scratch, mind posting a zip’d file of a Pyramid Project where this occurs and we can look at the MIDI data?

honestly, Im not really following this… are you saying this is only happening with CV now?

if so you can also monitor CV output levels in settings, obviously you will need to do this at a very slow speed, doing it slowly would also make it much clearer is going on.

really, you want to be slow enough to be able to see each note voltage level clearly… if you arp octaves, then this makes it easier for notes, as it’ll be one volt jumps.
not only will you be able to see the gate outputs moving, but also if the notes are stepping in 1v jumps (if using octaves) or slewing.

if I was to hazard a guess, whats is probably happening is the gate is going up/down for the ARP, but for some reason is then going high again due to you holding the pad down.

… but unclear to me if this is only for cv, and why this would happen.


have you reported this to Squarp as a bug report, this is always the best first step.

ultimately, it looks like an issue, and whilst we can discuss here to try to identify exactly the parameters of the issue - its the Squarp developers that need to understand whats going on, and then they are the only ones that can fix it.

I’ve not see anything here which would indicate its a ‘user error’, the only possiblity I see here of it not being a pyramid issue, is if its something to do witht the way your synthesizer/oscillator is reacting.
hence why Id try to test the same thing against a different synth, to see if you can replicate with other synths.

Sorry if my description was unclear, and thanks again for taking the time to help me.
To describe it clearly:

  • the problem happens both with CV and Midi devices
  • I’ve reset the settings and track settings, so as far as my understanding, the pyramid should be in an unaltered factory setting
  • I’ve just activated loop mode and put a arp fx on
  • the result is that the described behavior is happening from time to time
    my conclusion: this must be a bug
    I will make a bug report since it seems to be no issue with the settings or the synths.