Issue w/ Slaving Ableton Live to Pyramid


#1

I have a thread going w/ Ableton support, but it has not been very enlightening thus far. I was hoping someone here might be able to shed some light on the situation. My original message to Ableton support:

I am experimenting with syncing Live to external sequencers (e.g., Squarp Pyramid, Elektron Digitakt) and I have encountered an issue. When the external sequencer is stopped, Live’s “MIDI Track Out” indicator is lit and I cannot audition plug-in’s loaded in Live’s MIDI tracks. I assume that an “All Notes Off” message or something similar is being generated continuously by Live when the external sequencer is stopped, but I cannot verify this. I have not been able to find any documentation describing this behavior.

When Live is not synced to an external sequencer, and when Live’s sequencer is stopped, I do not experience the same behavior. This behavior is consistent with all external sequencers that I have experimented with syncing Live to, so I have to assume that Live is responsible for this behavior.

So, my question is: What is this MIDI message that Live is generating continuously when synced to an external sequencer that is stopped? Is there a way to disable this behavior? Is this behavior expected?

Ableton support responded:

This issue is localised to your Squarp and possibly the Elektron too.
I tested with a TR-8 and although the MIDI out indicator is permanently lit when Live is in Ext. sync mode, you can still audition plugins and instruments when the external sequencer is not running.

Further investigation reveals that the Squarp sends a MIDI stop with each clock tick when it isn’t playing. There should be a setting in the system which allows you to change this. We don’t have a Squarp though I can’t give any more guidance on that.

Can anyone confirm that the Pyramid sends a MIDI stop message w/ each clock tick when the sequencer is stopped? I didn’t find this in the manual. Also, I’ve never observed this when monitoring the MIDI Out messages under the Info menu. If I remember correctly, I’ve experienced this issue even when Pyramid is configured not to send clock when the sequencer is stopped.

If anyone can share any more information I’d appreciate it!


#2

Hi,

We don’t send a midi stop message with each clock. We have a setting SETTINGS > MIDI OUT > SYNC STOP which allows you to keep the clock regardless of the player state. I don’t know if Ableton needs a clock if the master is stopped but one value of this setting should do the trick.

Best,


#3

Good to know. Setting “SYNC STOP” to “OFF” did the trick.

I wonder now whether this behavior is inherent to Live’s handling of clock messages when the sequencer is stopped, or whether the behavior is specific to certain plug-ins.