Hermod step sequencer won't start

Hi, first timer here, so apologies if this has been asked already.
I followed Hermod’s first tutorial from Squarp, also the True Cuckoo one, and when in Step, my sequencer just doesn’t start at all. Could I be missing something?
Is there a way of resetting the whole module to factory settings?
I’ve installed the latest firmware.
Many thanks!

Hi Tiago,

I would suspect your Hermod is configured to use an external clock, and because it doesn’t receive it, it just waits.
You can change your “CLOCK SOURCE” to “INTERNAL” in the settings, as per the manual.

Let me know if that works

Hi @Thibault_Squarp,
thanks for the quick reply. I just checked the clock source settings and it’s set to internal.
I managed to get it to work now by creating a new project. I saw that step on the tutorial by Red Means Recording. I’m not entirely sure if this is what I should be doing as I didn’t see that step being shown in any other tutorials.

Glad you got it to work !
I’ll file a bug report anyway so we can investigate this further.

1 Like

Great.
The setup I’ve got is Keystep connected to USB host. I’ve got CV going to V/Oct on Plaits and gate to a Pittsburgh envelope. I’ve got the latest hermodOS 1.61.
The steps I’ve taken are the ones following the True Cuckoo video.
Thanks a lot!