Hermod midi / host conflict?

Hello! New poster, but a big fan of my Hermod.

I’m having a gnarly issue though- if I slave it to midi clock, and use the USB host port to play notes in, it freaks! at first no notes play, then they come tumbling out in a flurry, then it usually winds up with a stuck note and I have to reboot…

It’s a shame I’m having such a hard time getting clock and polyphonic inputs to this!! If I use a CV pair I can get mono in without a conflict. But using a Gate clock hasn’t been as reliable, plus it doesn’t start and stop like it does with midi… When i sync with my Daw via the DEVICE port, then clock and polyphonic midi info comes in no problem… But I’m trying to get away from the computer :slight_smile:

Any thoughts?


Hmm, both work for me …
I use usb device - when using my iConnect MioXM, and use host if I’m connecting the pyramid directly.

What your describing sounds a bit like a midi feedback loop

Are you on the latest firmware? There was an old issue with it retransmit clock to all parts which would cause a midi feedback loop.

Hello! thanks for your response. I have updated to 1.42. Still having this crazy problem. Any other suggestions would be welcome!


I’m having a similar issue… I have the Hermod clocked via CV to a Pam’s New Workout. It works really great… BUT if I also have a keyboard connected to the USB Host port then the clock gets off even after only a sequence or two. Happens pretty reliably, even though it’s not getting any sort of clock via MIDI (only CV), somehow there seems to be a conflict when a USB device is present at all. Bummer, going to write to Squarp support so they have the issue logged (if they don’t know about it already).

not quite sure I follow what your problem is… or exactly what you have setup.

are you seeing same behaviour as OP (with flurry of notes) … or just issues with clock (which sounds like a different issue)

you have clock source = CV A (?) … in which case nothing on the usb host port should affect the clock.

the only issue I have in this configuration, is that clock source = CV A , will also send out midi clock to all usb device/host/din… which in my setup could create a duplicate clock.
this will be resolved in 1.43, which allows a “CV x no clock” option, which acts in a similar way to ‘DEV no clock’

anyway log issue on https://squarp.net/contact

it sounds a bit weird to me, so make sure you include as many details as possible
e.g. what controllers are you using? what have you tried?, does it work with other controllers? what settings do you have on hermod?

I’m realizing this morning as I do more tests that the clock might be getting off for some other reason (even with nothing connected to USB host input). I tried switching the input clock (PNW) from 1/32 to 1/16 and it seems to be a bit more stable, but the jury is still out.

I will say that the clock getting out of sync seems to happen sooner if I have a USB device connected (in my case it’s a very simple m-audio keystation mini 32 controller). I’m wondering if that may be due to this keyboard being USB bus powered, and it drawing power from the Hermod (maybe that causes some voltage fluctuations somewhere?). I’ve also had a few issues with pitch going to a digital osc (Klavis Twin Waves) getting flat here and there, also while this is connected to USB.

In either event, I have more tests to do before I rule everything out, and I have a Pam’s expander on the way to see if MIDI clock proves more stable.

1 Like