Hermod clock stability issue - midi port

Hello everybody,

I have an issue with my Hermod, which is quite annoying. I am syncing the clock of Hermod to my DAW (Live) using the midi port. I can then define a clock out in one of the 8 ports and it can control quite precisely other instruments, great !

However I noticed an issue by trying to sync the clock out of Hermod to my delay (Echophon MN). It does not work precisely since the synced delay time is changing continuously creating some kind of pitch shifted echos when I should obtain steady echos.

When I press on the two BPM buttons on Hermod, I can indeed see that the BMP is continously changing with some kind of small random variations around the DAW clock. It seems that the transmitted clock is not precise enough and cannot be fully steady.

When I shift back to internal clock mode, the problem disappears.

Did you experience this issue too ? Any idea on how to solve this ?

Thanks in advance,


its pretty common for clocks from daws to shift around by small amounts.
basically usb midi on general purpose computer (mac,windows etc) does not have guaranteed timing, so it shift around by very small amounts - which leads to small bpm changes.
(how much it varies, depends on your computer setup - for some its better than others)

if you search this forum, you’ll find this has been discussed alot - not only for hermod but also pyramid.
(also beyond this forum , you’ll see it discussed with other products)

… and you’ll find various solutions discussed. (incl hardware with things like ERM multiclock)

solutions pretty much depend on where you want to compromise…
e.g. in this scenario you might

  • run Hermod as the master clock, and slave live to it
  • run hermod at a fixed BPM, and simple use the transport from Live to start/stop … so not the clock.

sorry, i know thats not what you want to hear… we all just want to plug in usb midi clock and it works but unfortunately, its usb midi from computers has its flaws :frowning: (*)

(*) how much you notice this variation, and how much affect it has on your music, also varies alot between musicians… those that need it really tight on grid find it frustrating, others hardly notice/care about it.

1 Like

Thanks a lot “technobear” for your detailled answer ! I tried to find other users with similar issues on the forum but did not find any thread on the topic. However I am glad to see that it is a somehow common problem and that there are work around.

You mention this solution which seems ideal to me:

  • run hermod at a fixed BPM, and simple use the transport from Live to start/stop … so not the clock.

I had this idea but could not figure out in the manual how to set it up. I would still need to use the midi in, sync the clock of the DAW but how should I tell Hermod to get only the start/stop signals and not the BPM ?

Thanks a lot !

1 Like

send a timing pulse from the daw as audio and use a CV input on Hermod and clock to that… the audio should track perfectly to the daws timing… thats how the third party daw midi clock devices generally work…

sorry, I confused the hermod midi options with the Pyramid
I just checked, and the hermod does not allow transport only over midi (unlike pyramid)

you could perhaps send a feature request to squap via their contact form for this feature - as it would be pretty handy :slight_smile:

as @radar says you could try sending a pulse from a daw as CV input.
however, usually this would require a DC coupled audio interface (this is what 3rd party hardware use).

but its worth trying… if you use something like Ableton Live or Bitwig these have a dedicated ‘cv clock’ device which can be used.
however, it MAY not work… the voltage level on a traditional audio interface is pretty low, and may not be high enough, and the AC coupling may smooth it out too much - in both cases, the Hermod might see it as the clock signal it needs.
it it does work, its likely you can use same approach for both clock and transport.

of course, this assumes you have some spare audio output channels.

timing via audio will be good, but bare in mind - it will be affected by your audio interface settings , so buffer size/sample rate

This feature would be killer!

1 Like

yeah, I agree this would be really useful ( i do like the way this is done on the pyramid)

Thanks a lot for the feedbacks and ideas ! I will write a feature request and check our what I can get from Ableton and pulses in the mean time

1 Like

Watched a Surgeon interview today and he sends a audio trigger click from the Octatrack to his MN Triggy… and syncs his whole midi CV rig that what…
not the same devices as Hermod of course but the principle is simi

1 Like

I think Make Noise also have an audio file for Tempi and DAWs specifically for syncing.

It’s worth noting that Echophon is very sensitive to the tiniest of clock changes.

1 Like

I have a tempi also… will be need two look up this MN file you mentioned. thx

Have you tried slave the DAW to Hermod?

whats your question?

many of us slave hermod to a DAW and vice versa…

alot of the time, if I do this however, I dont bother using the clock within hermod.
if I have a DAW open, I just record the midi in the daw - then use hermod as a midi 2 cv interface :slight_smile:

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.