hapaxOS BETA 1.12RC3

available here

I know, I know, never release on a friday, but eh, it’s a beta version, with minor changes, what could go wrong? *

* famous last words


Thanks Thibault,
I’m glad to be able to support the fw development in this way. :nerd_face: :ok_hand:

And for all young and impetuous sequencer pioneers:
Projects saved with fw1.12rc3 can no longer be opened with fw1.12rc2! :grimacing: :open_mouth: :stuck_out_tongue_winking_eye:
At least in my case. As always: Safety first! :wink: :nerd_face:

Poly aftertouch support is temporarily disabled in this version. It will no longer record nor play. Previous versions supported poly aftertouch very poorly, as such we prefer disabling it for the time being. Adding full support for it is a priority and will come in a future release.

How does this relate to MPE?

BTW, how about somebody unpinned the old 1.0something update that is always on top. It is very outdated, but could confuse somebody just arriving.

Zero impact on MPE


" * MISC setting: MIDI MONITOR (show all or only selected midi messages)"

the addition of filtering options on the native Midi Monitor is very helpful. many thanks.


oops got it sorted.

in case anyone else does the same thing i did:
the hapax.bin file needs to be dragged into the main SD card folder, not into the SD card > HAPAX folder.

and obv follow the instructions, including:

  • power on Hapax while holding the main encoder and wait for the flashing procedure to complete.


1 Like

I was amazed at how quickly they responded to our requests. Awesome team!:tada:

One new feature I overlooked at first in RC2 is the Active Track Port/Channel. This looks like a pretty cool addition I hadn’t dared ask for.

Can anyone elaborate a little on how this is meant to work, please?

My understanding is that I could have a synth module, say, on Port A, CH 6, both In+Out, so I can both record and playback CC for example. At the same time I have a master keyboard on Port B, CH16 which, thanks to the new feature can now also play that synth module when the track is active.

I’ve run into two issues:
The issue I immediately ran into of course, is that synths that don’t support “local off” create a midi feedback loop. If I now change the Midi In CC, Pressure, etc to “REC ONLY” (which is a global setting), the loop is gone, but the ones that do support local off don’t work anymore and since the mod wheel is CC1 I can’t use the one on my master keyboard anymore in any case. Not sure how I’d want this to work, TBH. I guess, if local is supposed to stay on, whatever comes from the ACTIVE TRACK+CH should be routed to the synth, even when the MIDI input setting is REC ONLY.

The second issue I found, as soon as I had activated that active track port, notes got stuck. Or rather always exactly one note. Both when played via Hapax and the master keyboard. But only on synths which also had an In Port+Channel configured, didn’t happen with ALLACTIVE+NULL.

A third issue I found, though maybe unrelated, when configuring a track with Midi Out on port C, but Midi In on USBD incoming CC from a synth with local off will not get forwarded from USBD In, CH1 to C Out, CH1. Whereas forwarding will work from A In, CH1 to A Out, CH1.

I will file a bug report, but first I wanted to find out whether I understood the purpose of the setting correctly.

I guess before this thread is closed, I’d like to add the Active Track Port/CH feature actually works really well :slight_smile: I simply had a Midi loop in a place I hadn’t suspected at all. That’s what you get for chaining multiple routers.