Hapax crashing on effects and automation

While studying the Hapax tonight, I ran into situations where I’m not able to use the device crash-free for more than a few minutes.

Is anyone else experiencing this?

So far this seems to be while adding effects or automation. I submitted a bug report, but wanted to ask here as well to see if anyone else was seeing this:

I found a recurring issue last night when trying to add interpolation onto a recorded CC lane. The error said “Lane does not exist in pattern but should” but it didn’t seem to crash the whole Hapax.

1 Like

There are still some gremlins, and I’m sure as we get more users playing , this will unearth some more.

The best way for us to get these fixed is quality bug reports submitted via the contact form

What’s does “quality” mean?

The best bug reports are ones that isolate the issue as much as possible … so are reproducible.

Start a new project
Add chance fx
Add automation lane for chance fx / rate
Delete chance fx, causes a crash

This makes it easy for a developer to reproduce , so determine cause of bug , and also once a fix is created be able to test it works.

Please also include picture of any error messages on displays.

Example of ‘bad report’
I’ve was playing with this (massive) project for an hour, deleted an fx and it crashed - here is the project.

The issue is, it gives the developers no real way to reproduce the issue or drill down into where the error is… it’s not much better than just saying ‘it crashed’ :wink:

Hint/tip from a developer:

As a dev I will always look at good bug reports first … simply because they often are quick fixes … a vague report, means I know I have to do the research so is going to be more time consuming… so has to be ‘scheduled’

So you want your bug to be fixed asap … quality bug reports :wink:


Maybe there should be a sticky thread in the forum about filing bug reports and feature requests!


Great advice!

I’ve been a professional software engineer since the 90s, so I certainly appreciate a good bug report. Unfortunately, I’m not able to reliably reproduce the freeze. I’m going to keep a close eye now to see if I notice something obvious.

In the meantime — this is how it can be with early products, so no harm on my end! The team at Squarp were super fast to respond and are working on it.

I’m having a blast and I’m sure future updates will fix the “gremlins” and a whole lot more :slight_smile:


Happened again once today while working on the arpeggiator. I still can’t reproduce the freezes on demand, but so far they’ve been within the automation or effects functions.

Side note — the Hapax is so fun to use and it’s built in such away that allows muscle memory to kick in extremely fast. I’m really surprised by the workflow :metal:t3:

I’m getting lots of freezing just doing simple things like entering notes in a drum track. Got it to freeze when adjust the program change parameter, wasn’t even actually sending one just trying out the UI. I can’t reproduce it reliably. Honestly it froze twice within the first 5 minutes of turning it on. Wonder if I got a defective unit.

As soon as I can find a pattern I’ll submit a bug report. Not sure that “random freezing” will help them much.

Ah bummer. I recommend submitting a report; maybe they’ll be able to triangulate. They can also perhaps look at the serial numbers to see a pattern that we can’t.

Yeah I’m gonna have to, another two crashes since I last posted.

Ok bug report submitted with one way to get it to freeze consistently.

If anyone is interested in trying here are the steps:

  1. Turn on Hapax with only the power connected
  2. Press play
  3. Hold track and apply a program change a couple times
  4. Go to effects and add CC 0 as a source
  5. Attempt to add a destination
  6. Freeze
1 Like

I just tried this 5-6 times and it crashed once, but the other times kept playing. Thanks for the tip! I’m going to continue trying for a reliable sequence.

Does this sequence of events reproduce it every time for you?

I was able to reproduce it 5 times in a row. I made a video but the contact form kept failing when I attached it.

Seemed like if I bounced around in the program change section for a few seconds then went to the mod matrix it would always fail.

This is not the only situation I’ve run into. Going to try and find the other ones. Once I was just entering notes in poly mode.

I reproduced your issue a couple times, but perhaps I was doing something a little different.

Also, I found a separate issue with the knobs not registering button presses but I’ll make a new thread in a few minutes.

Heard back from Squarp already. They were able to reproduce the issue and are working on it!

They also reassured me that all freezes will be fixed ASAP and we’re very gracious for the bug report.

Thanks Squarp!