[FIXED] Will you please fix that gate bug!

Had it for the first time too now, also a USB Midi controller (Keystep via USB cable)

I’m just happy to see I’m not the only one

I’m also having this issue with a keystep using the Hermod as the USB host. Weirdly, when it happens it tends to be when the keystep is played rapidly, however I don’t know if it’s the keystep because the lights on the hermod still appear to light up brighter, making it look like typical feedback for normal behavior. It’s really hard to reproduce and I’ve personally tried to find some key pattern to predict it. Sometimes I can go a whole session without it happening, and then other times I start working around “dead” channels because it happens so often. I do feel like the frequency of notes being played has something to do with it, but even when I clear the steps mode it can happen. I feel like this is the same scenario with the note overhang. I think the hardest part about fixing it is that it seems to happen over time (I know that’s the worst as well), and I feel like my unit is more likely to freeze when tracks start dying from this issue.

Also having the same keystep usb problem. Stuck notes. It stops when I stop and start the sequencer or vice versa. Huge bummer.

HI, I joined to also say that I just bought the Hermod two weeks ago and now am going to sell it. I’m very disappointed in the response from Squarp (Blaming arturia keystep) and having to develop a new FX just to fix the legato/ gate issue. If I understand correctly, the new fx will just have to be applied all the time to avoid stuck notes and so I’ll lose one of 8 fx? Very frustrating.

I’ve had stuck notes and gates not firing with every single session on the Hermod. I used the Arturia keystep in both midi and usb and I tried to use my m-audio 02 in midi and had the same problems. I’m MOSTLY experiencing gate being stuck and never firing again. I have to power cycle the hermod just to get back to playing and then it repeats, over and over and over.

unfortunately I am so frustrated with this device and the fact that Squarp is now claiming they will not develop it further that I’m returning it. I think it’s a real shame that Squarp would release a beta build and then blame other manufacturers for your problems.

Hard to beleive this issue is still here, sold mine a while back when I was told this wans’t a bug but a feature, lol.

Hi guys,

There is multiple issues in the thread, caused by different origins, but the result is the same: a GATE problem. USB issues are quite hard to fix, as every manufacturer uses slightly different USB drivers, this is why it can be long for us to fix these issues.

About 1.
This behavior is intended and it has nothing in common with the Arturia Keystep. We added this new option in the ‘MIDI’ FX, for the next release. @screamingzen you will not have to apply it all the time, only if needed. You are not gonna loose an FX slot (it is included in the first one which is always present). I don’t think this is your issue. @bitbin this will resolve yours!

About 2.
The Arturia Keystep is causing this problem. We worked hard to understand what’s going on with this controller and why we have stuck notes when this controller is used through USB host. Good news, we finally fixed it and we will send a beta version to most of you. We are still testing the new hermodOS version, we plan to release it soon!

About 3.
We are starting to doubt about the existence of this one, it’s maybe linked to the 1 or 2 problem. If someone find anything not related to 1. and 2. please let us know. We also improved the real time processing of hermodOS and its stability, in order to prevent that kind of random, rare problem.

Thanks a lot for your patience! If someone want to give a try on the new firmware beta version in order to check 1. 2. or 3. we will be happy to send you the firmware.

@screamingzen We are working on a new firmware version, not adding new major features doesn’t mean we stopped Hermod development or maintenance. Like the Pyramid Sequencer, our goal is to create a stable and robust machine.


Ok, I’m a little scared because you sound like you’ve fixed this thing, but I only have a limited window with which to return it. So what you’re saying is that in october you’ll release a new OS that fixes all the stuck note bugs? and that Legato functionality will be available through an FX slot? Does this also mean that if I play notes rapidly it will not longer detect it as a legato and therefore miss a note? because that’s the other problem… playing notes in rapid succession causes missed notes, and my understanding is I’ll then have to apply an fx slot to stop missing notes if I’m playing rapidly?

The scenario I’m describing is when trying to play Mutable instruments rings like a strummed chord. Since it’s monophonic, the notes have to be rolled rapidly to simulate a chord, and I end up missing notes because it sounds like it’s detecting legato and therefore not firing? I saw this technique by the artist Ann Annie on youtube. I literally bought this thing because of the awesome recommendations by Ann Annie and Cuckoo, but all i’ve had is nothing but problems and I’ve no idea how they got theirs to work. perhaps I just have a defective unit?

I really wanted to keep this thing, and I was going to return it today, but now I’m confused. You’ve def fixed the USB issue with keystep and stuck notes?

One last thing, I do have some crap videos I could share with you of my problems with USB and Midi. I just don’t want to post on youtube just to share a link. If you want, I can email them to you.

I have had the same issues since day one and my sound modules are 2 rings and a plucks I almost thought the pluck was broken but turns out it’s the hermod very disappointed but I hope they fix this and make it right otherwise many people will be looking for a new brain for their system

@screamingzen Yes, don’t worry, we fixed the bug with the Keystep connected to the USB HOST causing stuck notes. It’s already stress tested and the bug is definitely gone.

The “legato” new feature will be available through an FX slot, you can enable/disable it on each track. In the effect MIDI if you set GATE RETRIG = ON, each new played note will trig again the GATE, even if notes are overlapping, so it will not act as a legato as before.


Great news!

@squarpadmin, ok man, you convinced me to hang on. I was playing with this thing last night and I really do love all the FX features and all the gate and cv outs for such a small HP and cost. It’s been a dream of mine to own this, and I finally got it. If the stuck note issues get fixed, I’ll be a fan for sure.

one side question, is the delay supposed to work as full on for each bounce? I can’t seem to get it to fade off as it delays. so for like 3 delays it is full on for each delay and then stops. Am I not setting something right?

Can I join your beta testing and get ahold of the new firmware?

We will soon release the final OS, no beta needed for this version :slight_smile:

The delay fade off but you need to use a voice with a velocity to get that fade (track layout = 2 voices, MONO + VEL)

1 Like

@squarpadmin Oh dang, I’m such a noob. lol. I should have realized. thank you for addressing my concerns :smiley:

Hi everybody, good news, the new version of Hermod (1.10) is online: your gate problem is now fixed!

Thanks a lot for your patience and reporting.


Can someone confirm this has been fixed?

@squarpadmin I am now getting a similar bug with ROLI blocks, in addition to inverted AfterTouch, as noted in support tickets.

@Worldwave the GATE problem is fixed since 1.10
Thanks for reporting your other issue about the ROLI, not linked to the discussed bug.