[FIXED] Will you please fix that gate bug!

@squarpadmin I’ve had that bug from day one with the Hermod and it’s really annoying the hell out of me, Each time I’m recording either CV or midi the gate stop being triggered! the only dumb work around if I don’t want to power cycle the module is to add whaever fx you want to the track and then delete it, then the gates start working again. Please fix this! this is stupid.



And an other bug similar to this one : sometimes the CV OUT of one track keeps emitting a fixed note.

When you input an other note, using midi keyboard or CV IN, the CV OUT displays the new note but as soon as you stop playing this new note, the fixed note starts playing again… even if there is no note in the sequencer…

To fix this, you have to insert a scale effect and then delete it after…

Really really really annoying.

1 Like


Actually dropped notes and stuck notes can be the same issue (if you miss a note on -> dropped note, if you miss a note on -> stuck note). We really want to take care of this one quickly but we are unable to reproduce it so far. Mathieu was wondering on the previous thread if it can be a USB host issue ? I am sending Arpeggiated notes from Pyramid with a rate of 1/32 at 300 BPM (really really fast) for 20 minutes now and Hermod didn’t missed or stuck any note. We have to find precisely what’s happening here in order to fix it. Can you give me a precise procedure of how you get these dropped gates ? Do you still have this issue when using the midi in port ?


@squarpadmin I’ll find the time and take a video of the bug if you are talking about the one where the gates stopped being triggered after recording either midi or CV can’t comment on @Distances bug though.


So here it is, unfortunately there is no reproducible steps as it just happens randomly while playing around, I’m not doing anything crazy other than recording/deleting/editing, sometimes unpluging the CV A/B input so I don’t have the overdubbing. I didn’t record the whole session as this bug is unpredictable just started filming when the bug happened :

Really hope you can fix this one because this happens everytime. This and the lack of legato/mono mode to fix that gates drop when notes are overlapping are bigs ones that we shouldn’t have to deal with. thanks hope you can sort this out.

Hi @madeinspace,

Thanks for this video. Ok so, it happens only after a while (the worst ones !).

  1. Do you have this bug only when you record CV/GATE ?
  2. When it’s stuck, did you try to press STOP/PLAY ? Does it unlock the note ?
  3. When it happens is the gate locked in high position or low position ?

Anybody else has this issue ?

Thanks for your help !

@squarpadmin No worries,

  1. It also happens when recording midi (OP-1 in that instance)
  2. stop/play have no effect, the only fix is to ad an FX to the track
  3. the gate is stuck in high position



Hey, still no fix for this bug ?

This is driving me crazy, yesterday the gates stopped working during a live stage… First and last time I bring my Hermod for Live. This is lame.

1 Like

Just my 2 cents in regards to this bug. I have never encountered it before and seeing as, so far, only three people have reported it, it could be either very rare or a hardware issue?

Perhaps it would help @squarpadmin fix the bug if there was a better documentation of the bug. I’ll give a shot at breaking the gate and see if I can reproduce the steps.

Edit: just tried feeding Hermod very fast gates, but it did not break it. It worked like a champ! Here’s a video https://streamable.com/lltgi

Hi @Zijn,
Thanks for the video but the gate coming from PW in your video may be very short pulses whereby we are having issues whereby gates are long and are exactly starting when one ends. So it would be unlikely you would have this issue demonstrated in your scenario.

Here I can show you visually in this video:

I just signed up to report exactly the same issues as above. I’ve only had mine a few days, and pretty disappointed, still considering a refund but I wish this wasn’t the case, as the Hermod covers a lot of features that are important to me.

I’ve been experiencing stuck gates (occasionally), hanging notes (very often) and also unstable pitches (occasionally).

In my case though, I think it’s mostly been while using my Arturia Keystep (via the USB in) when these issues have happened. Except for a couple of cases of the stuck gate, which just happened randomly IIRC.

I see what you mean, but from what I can recal using different midi to CV interfaces this is quite common. I think it’s because the sequencer sends a note on/note off message the same time. Because it happens on command I’d catogorize as a missing feature rather than a bug?

I’ll create a long gate on Hermod to try and isolate the issue. If the gate resets on Hermod in standalone mode it could be a bug in the external sequence processing, if not it’s probably a missing feature.

To create long notes with CV I usually send a short gate to the envelope with a long release.

Hi @Zijn

This has already been noted by Squarp and they intend to sort this out in the next release so that we are able to carry this desired functionality.


Great! I just tested note on/note off on the Hermod’s own sequencer and did not run into any issues. However, with external notes coming in from Live I do get the issue as seen in the video.

jee can’t believe it is still there! I sold my hermod, might consider it again when all these bugs have been eradicated

I also experience the stuck MIDI notes bug and I can recreate it easily. I just made a Youtube video where I reproduce it a few times: https://youtu.be/QNFIMcskNYo

In the video, an Arturia Keystep is connected to and powered by the Hermod via the USB Host port. The Hermod’s MIDI Out port goes to a Boomstar and then through to a Streichfett. The Streichfett is what I’m actually playing in the video. Channel 1 on the Hermod has the MIDI Out effect configured to the Streichfett’s MIDI channel (channel 2 I think; the Boomstar is on channel 1). The Hermod is not running, it’s just being used as a USB to MIDI converter, but I can get the same results when I play sequences through the Hermod’s MIDI out.

Edit: note the USB going into the Streichfett is only for power. It’s just connected to a USB power supply.I unplug it and plug it back in a couple times during the video to clear the stuck notes, since the Streichfett does not have an on/off switch.

Does this only happen when using Hermod? Have you tried the same with a direct connection from the Keystep to the Strechfett? I’ve got a Moog Sub Phatty that often gets stuck notes when sequencing it from any sequencer.

This has been happening to me as well since day one been a real burden, I have tried multiple different midi controllers all with the same issue. Seems to always happen at some point in a session making this module almost use less


Actually we have multiple « things » going on at the same time it is very important to avoid misleading information to find the real bug :

  1. If a new note is sent exactly at the same time than a the previous note on, it’s interpreted as a legato. Overlapping notes don’t trig a new gate. This behaviour is intended (check this post : Hermod firmware update 1.03). We will add in the next HermodOs a new FX Output setting to separate each notes, in order to avoid glide/legato, and always trigger the gate when a new note is sent. Let’s call it the overlapping issue

  2. We have an Arturia Keystep here at Squarp and we experienced stuck notes when we play a lot of notes at the same time. It’s likely to come from the controller. For those using this one can you try with another controller to check if it’s still happening ? keystep issue

  3. Apparently, some of you have another bug. Gates are working and at a precise point in time it stops to work. This is the one we need to find, the unknown bug. We tried a lot of things to reproduce this weird behavior with no luck. If someone is able to reproduce it please let us know how, which controller you use and what are your sync settings.

Please do not use an Usb hub between Hermod and your controllers.


1 Like

I had lots of stuck notes via Keystep into USB, until I switched to MIDI. I haven’t had stuck notes since, but I’m also going through a Digitakt first, then into the Hermod. Don’t know if that helps at all, but the USB input was definitely causing me some issues.