Confused about using patterns in live mode

Is there a way to switch between patterns in live mode that doesn’t cut off the currently playing pattern? I have start set to one bar so things stay in sync, and it seems that as soon as I switch patterns the first one cuts out and nothing starts playing until the start of the next bar. Is this expected behavior?

Check out your pattern delay setting. I don’t do live stuff so no comment on expected behavior.

Thanks, I have both trackmute delay and pattern delay set to the sequence setting which is 1 bar, but when i switch patterns the mute is instant.

After some poking and prodding, I discovered that the settings only apply to changes made while in track mode with the pattern selection screen up. If you use the “Hold STEP button and press a pad” to change patterns in live mode or step mode, the mute happens instantly regardless of settings.

1 Like

There are two options to change Patterns.
A) Press STEP + Pad to change patern immediately
B) Press STEP + TRACK and than you can select the next pattern. It is then changed according to the delay settings.


Interesting, I knew those two ways of switching patterns but had no idea they’d behave differently in some setting. In my own use I only ever change patterns to assign one to a sequence with the player stopped, and beyond that only switch between sequences.

what do you mean by mute is instant?
(i view mutes and pattern changing as very separate things)

are you saying the pattern that is currently playing is instantly stopped, but the new pattern is only started (correctly) according to the pattern delay.

its been mentioned previously (on the forum) that the behaviour is slightly different between using STEP+ PAD and STEP+TRACK : PAD . in the manual it does not mention this, it implies they are equivlent.

however, we don’t know if the manual is inaccurate (and its expected behaviour) or its a bug.
I suggest you raise a bug with Squarp via the contact form and they can inform you if its working ‘as expected’ or they agree it should be changed.

not sure your setup, but i have my sequence changes set to change at 4 bars, and i usually do my pattern switching that way. i don’t have any odd artifacts doing this.

I think what I’m observing can be explained in this way:

When in live mode, changing patterns using the shortcut is instantaneous, just like @laux_laux describes. This is unexpected to me. I would expect live mode, being the performance oriented mode, would work on the beat.

The reason it’s disruptive is due to the timing and lengths of the notes in the project i observed it in.

The pyramid does not chase notes. Meaning if a note on event occurs in a free running pattern prior to changing to that pattern, that note will not be played. In my case, those notes last for 2 bars, which means if a switch occurs between bars 1 and 2, no sound will play for one bar, and then notes will resume at the nest observed note on event.

This lack of note chase is a major difference between the pyramid and most DAWs and emphasizes the importance of note timing and means long passages and drones need to have extra attention paid to them to work as expected when changing patterns

1 Like

this is the way

dont most daws suffer from the same problam

Both daws I’ve used, Logic and Ableton 10, have options to note chase that work perfectly.

so , I played with this a bit… yeah, its as you say.

whilst I was playing though, I found that this shortcut (STEP+PAD) I was mainly using whilst edting patterns - so in that context it kind of made sense for the change to be instant.
I guess (but who knows!) squarp thought tthe pattern screen (STEP+TRACK) was more useful in a performance context (and STEP+PAD during composition?!)

btw: i don’t see there is a lack of ‘chase note’, it already does it, with STEP+TRACK, rather its down to if the STEP+PAD shortcut should adhere to the pattern delay or not…
but as I said initially, that is not really is up to any of us here…

this is something you need to discuss with Squarp (via contact form) and see what their thoughts are, what their reasoning is, and if they consider it a bug or a feature.
(as I mentioned, in the manual its unclear if this behaviour is intended or not)

1 Like

Since my other thread got locked thought I’d post here to say I fixed my issue by disabling Quantize - I had Human +/- 10% on it which I think was causing the problem.

1 Like

Yes. Humanize can push a note out so it won’t play. It doesn’t play nice with the sync chance effect either. In my experience humanize is best used on tracks that have already had the other desired effects applied and consolidated. Even then you need to be careful about note length and timing of pattern changes, or you’ll get caught out and miss a note on event.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.