Can’t consolidate tracks


#1

I’m trying to consolidate euclidian tracks but when I click ”cons” from track menu nothing happens.

Is there some step I’m missing?

I’m using 3.21.

Thanks


#2

It’s probably a bug, or a few:

Starting with an empty project,

  1. change track 1 to euclid mode
  2. consolidate, with track 2 as destination (this changes the current track to 2)
  3. change track 2 to euclid mode
  4. consolidate -> nothing happens

Edit: I reported this sequence to Squarp, but you might want to report it on your own with your project as a reproducer as there’s no telling if this is the same issue you’re seeing.


#3

Thanks! I will report my case as well.


#4

Ok seems like it was due to time sig settings being 16/16. (I use that w zoom level 1 as my default to get simple by-step increment lenghts)

Using 4/4 consolidate works as expected.