Avoiding MIDI loops / setup with kenton MERGER & THRU boxes

Glad this helped you.

Though you may consider an iConnectivity MIO MIDI interface in the future.

I sold most of my merge / thru boxes since I have 2 MIO’s. They’re really great and powerful MIDI devices, adding a lot more flexible routing and les cabling compared to using Kenton boxes or others.

I’m very happy with them, and their support is great too…

1 Like

I agree about iConnectivity, they are a great company. Great products, top support, really nice people who will bend over backwards to make the customer happy and genuinely too (well that is the impression I got when dealt with them). You forgot to mention, excellent USB MIDI connectivity.

BUT, I won’t be selling my other routers anytime soon, I like to change things quickly without needing a computer. I tend to attend to my MIO like a hardware firewall; set and forget until something new pops up and needs rules added for it.

1 Like

" midi input channel " also on my wish list by now :slight_smile:

3 Likes

Has someone used the new " anti echo / Auto midi A or B " ?

Live mode / recording :
Somehow discovered last night and had suddenly much better results ( less midi looping ) since switched on to " anti echo / midi B " .
Not sure why still sometime some notes can pass thru and creating annoying loops ( keep recording midis ) but the new options are far more efficient even still on record mode !

Paq

let me explain my current config, it might help some people strugling with midi loops and thru boxes:

Currently using 2 chains of 2x Emagic AMT8/Unitor (= 2x2x8 midi I/O = 32 midi I/O in total). These are midi interfaces, but can also function as midi patchbays, with some limitations. I use them mainly as patchbay.

All are configured so that every input sends to all outs, except its own.
with some exception for some input devices (midikeyboards and such) and the pyramid itself. it’s quite a complicated puzzle sometimes, so I document and plan in an Excel spreadsheet
one pair of ins and outs for each chain goes to the pyramid, the ins first into a midi switch (philip rees). Not a merger, because with the switch I can easily stop the pyramid from recording whatever someone else in the studio is playing live on the synths without having to dive into the pyramids menu

the pyramid is set to “anti echo” => “on”, so that the input does not go to the outputs (as my Emagic chain is handling that). With other sequencers (alesis mmt8 for instance) this would be called “midi echo” = “off”
currently very happy with this setup, as its more flexible.
also see this topic:
http://squarp.community/t/rename-anti-echo-to-midi-echo/1272

only downside i guess is i can not play synths from “chain 1” with keyboards from “chain 2”, and vice versa, but it would become complicated with the channel overlap anyway. I could do it if I change the pyramid “anti echo” config with one of the auto settings, but just thinking about the repercussions makes my head hurt

still have some other gear I would like to add, e.g. Atari with some synth editor software on it… but in the past I had midi loop issues with that so I’ll wait untill this current config is considered “stable” on its own.

2 Likes

Does someone know why we still get sometimes midi loops annoying returns ?

Set midi echo off by default and you’ll never get midi loops…

Hi , it’s even worse because it keeps re recording the sequence .
I Have especially issue now with Roland SH01 …

I must admit I have all roland Clans input and output attached into Squarp

I take it by “Clans” you mean all your Roland gear. And if they are all set to THRU then you that’d be why you are still getting a loop. You may need to get a splitter if you are chaining MIDI to get it to all of your instruments and then only have the one you wish to record from going back into the Pyramid.

If you are running more than two MIDI instruments off your sequencer and then send any of them back into it, it’s a good idea to draw a MIDI flowchart to visually analyse your set up. It really does help with pinpointing issues and acts as a reference for what’s going where when you are setting up sequence track MIDI channels.

2 Likes

Yeah . Got connected all Roland aira and boutique .
As we know the Roland boutique as pretty delicate sometimes to make it work especially using several midi merge and thru boxes .
Roland JP08 made tons of trouble and as well Sh01a .
I took those two and connected them via USB to midi ( thanks to midi patch bay OS X ) .
And seems to work finally much better .

Someone can share similar issue with those two combined with those midi merger boxes ?

Thanks
P.

As much as Roland squander their MIDI legacy with crappy implementation, there shouldn’t be an issue with using them before or after any powered merger or splitter.

1 Like

I am having a similar problems with the Pyramid on live recording mode. I am using it with the Kenton merge 8 and thru 12 with a minilogue, Roland SE-02, volca bass and keys (modded midi out) and Roland VP-03. I am getting lots of midi echos all the place :upside_down_face: I have tried Midi echo auto and Midi echo on but it does not seem to help. I read a few threads on this group saying you can fix it with some computer program but i don’t want to get the computer involved in the setup. Is there another setting I am missing or is the pyramid just not up to the job? If not, does anyone know of another unit which works? Thanks for the help!

1 Like

Hi ,

I tried as well midi echo off option and regular basis getting as well midi hanging notes …
Sometimes switching around the midi echo options

thank for this topic, learned a lot! is midi input channel already there?

Couple years since the start of this thread and this is still an issue. It sounds like Auto Echo killing has become more effective, but I’m actually now running into issues where sometimes notes aren’t played at all - I’m assuming because the Auto Echo function has killed them.

Can anyone explain what they mean by “midi imput channel”?

This is a very old thread. MIDI Loops have been an issue since…as long as there has been MIDI, I’d imagine.

Why do you think this is happening in your system?
Are you using Auto A or B setting on MIDI Echo and it’s not working as expected? Pls describe your data path and bevhaviours expected vs experienced. Also, it’s a good idea to strip down your connections/system to troubleshoot - just a matter of unplugging a few things. This helps narrow it down.

It would seem to me you’re experiencing a situation where “something” note events don’t get played. If this is intermittent, it would be difficult to duplicate, of course. I would suggest:

  • Ensuring that Chance is not present in your MIDI Fx
  • Check all your cables ensuring they are plugged in properly and in proper working order
  • Try to dupe
  • Review the MIDI Monitor to see how much data is being produced
  • If you can find how often it tends to happen, make a note of how long or approximately how much data you need to produce to repeat it. Example: It happens between 1-3min of playing a 1/16th note arpeggio.
  • Try to duplicate the problem armed with the data gleaned from the previous step with sending the data to a different synth (the problem can very well be the synth)
  • if you have a computer & DAW or MIDI Ox with your gear, it’s great to be able to record the MIDI on the other end, but probably not necessary
  • Strip down your rig, perhaps to the Pyramid and one synth and try to dupe. If you cannot duplicate at this point, check your data chain (mergers, thrus,cables, etc)
  • If you can dupe with just Pyramid sending data to one synth, and you can duplicate this with multiple synths, try to record the MIDI data and post it in a new thread here

In my limited experience, I would say that most dropped data isn’t the fault of the Pyramid, but due to synth OS, cable issues, data path corruption (too many devices…?), using THRU extensively (with synths that don’t really make THRU data a priority), or just shoving too much data through the path. Actually, the last bit seemed to be a big issue in the 80s for me, but I haven’t run into that problem since about the late 90s or so…well, except that I use synths from the 80s & 90s (still)

I have no idea what trendingtopic meant by this.
It may depend on what setting you have for Omni Mode, such as if you use MultiTrack Bank n or CHnn

As always, keep in mind this is community support - others may chime in, or even some of the previous posters from this thread. For Technical Support you’d want to visit squarp.net/contact. But it’s a good idea to perform due diligence ahead of time, which could very well resolve your issues.

Good luck!
I’m going to close this thread, because us posting here may be alerting those who posted over the last…oh 4+ years…?