Arpeggio different speed after recording

Quick setup: I’m clocking Hermod externally via midi from Pam’s NW Pexp2. I am using a Keystep keyboard via USB host to play notes into Hermod.

When I add an arpeggio effect to a track and audition it by holding down notes on my keystep everything works as expected. However, if I record what I’m playing and then play it back, the arpeggio speed is faster (I’m assuming double) what it was when I was auditioning it.

Do others experience this behavior? I’m curious to know why it’s happening and if there is anything I could do to correct it. Currently my work around is to drop by arpeggio speed setting down after I record to correct the offset.

Thank you.

Double clock rate is often observed when a device receives clock from multiple sources / MIDI loop issue.

When this happens to me I reduce the setup complexity by slowly removing devices one-by-one until the clock rate appears normal again then focus attention on the setting on that last device. I don’t have a Hermod, (perhaps one day), but have had similar issues with Pyramid. In my setup all devices connect via DIN to mio10 and if configure both Pyramid and NDLR control the same device, (e.g. Hydrasynth) then clock is doubled. This is resolved by reconfiguring the mio to allow the Hydra to be controlled by either NDLR or Pyramid, not both. In my setup the mio, Pyramid and NDLR all get power from the same powered USB Hub, and believe that’s where the dbl-clock rate manifests. Think there’s a bug in one of those devices as that shouldn’t happen but it does. Probably need to do another factory reset on the mio…

Anyway, sorry for the long response. Hope this explanation helps you uncover the source of the issue.