Any way to Change the pattern chain in play Mode?(Pyramid)


#1

While in play sequence Mode I noticed that patterns Change on the fourth Beat of the Last bar, and that patterns dont start always on the first bar (if you for example have two 1 bar patterns and then Change to a 4 bar pattern it Will start from the 3rd). Is there any way to Change This? I normally want the New pattern to Change on the first Beat of the first bar, and to start a pattern from its first bar when changing the pattern.


#2

The Pyramid defaults to what is a fairly unique “free run” track mode, which can doe stuff that the average sequencer can’t, but also strange artifacts if you’re not planning for it. Sounds like you’d prefer the more traditional “relatch” mode. Been there, life with Pyramid only really started making sense for me once I switched the default to “relatch”.

The track run mode can be different for each track, and you can also change the default in the settings, see https://squarp.net/modeseq#ancre09


#3

Hello, thank you. Didnt quite understand its implications when reading that part. Changed all my tracks to relatch. Could easily play the part where freerun Mode was making trouble. But now, tracks fall out of sync… Most of the times, not always and that makes it even worse. Let me explain it in case its a configuration problem.
Im writing a song with This structure:
Sequence 1: a muted bass line in track 2 with 4 bars. Playing four times. A lead with 4 bars Playing. A track with a program change for my drum brute impact, loading a blank pattern.
Sequence 2: the bass line isnt muted anymore, and there is another program Change in the dbi track and start to play some bassdrums. When changing the sequence, the first hit of the drum brute impact is on time (checked 4 or 5 times with a metronome), the pyramid Most of the times skips a Beat and play one Beat forward. Sometimes doesnt.
For me This shows an evident lack of stability in the machine. Anyway. Any solution?


#4

In my experience the Pyramid is very stable. Bugs are of course always a possibility - in all involved devices! See eg https://forum.arturia.com/index.php?topic=90169.0

Anyway, I’d start by verifying sync settings on both ends.

Is the missed beat truly random or actually something like every n’th one?
Truly random suggests clock or hardware issues of some sort, periodic issues are more likely something else: Different signatures and track lengths together with polymeter/polyrhytms can create all sorts of “interesting” effects in relatch mode too. Then the live looper feature can apparently affect the start step: Track start step wrong. Another sort of related common issue is missing the first note of a sequence because it’s timing is a little early, but then it plays when looped.


#5

No, the problem is in the pyramid, Maybe because im doing something wrong. I used before an arturia beatstep pro and was Just working how I think its supposed to be. When chaining patterns, they start on the first Beat of the first bar, and play the 4 beats of each bar.
The patterns are live recorded. When chaining patterns while on latch Mode, they skip a Beat, not a note. They start on the fourth Beat of the fourth bar (its shown on the pyramid also, I Could record a video),instead of the first Beat of the first bar, no sync problems among gear, the dbi stays perfectly on the Beat seen as first even on the pyramid screen. Its the pyramid making the Last repetition pf a pattern 3 full bars and 3 beats instead of 4 full bars.


#6

Didi you check the live looper thing, ie this thread: Track start step wrong ? Other than that, I’m running out of ideas for the night.


#7

Now I did, is off. The problem was still there when I was using the free run Mode, but it played the note on the next pattern’s 4th Beat and was ok. But with the latch Mode it skips a Beat and everything falls out of sync